No delivery statistics for recent sendings in APSIS One

Incident Report for Apsis One

Resolved

It was determined that our service responsible for processing sending stats was dealing with elevated traffic that translated into delay in processing those events. Situation was mitigated by the response team and we see statistics being displayed on the accounts as expected. Incident is resolved.
Posted Aug 14, 2025 - 12:50 CEST

Investigating

We've discovered an issue with email delivery statistics (sent, open, delivered) available on accounts in both, email page and report page for emails sent since yesterday ~14:00. Our initial investigation suggest the data exist and is available through segmentation tool, but we fail to deliver it to respective pages. Incident response team is looking into it
Posted Aug 14, 2025 - 10:05 CEST
This incident affected: Email Tool.